Avatar
NEXT
Neregistrovaný
Avatar
NEXT:

Ahoj, dělám takovou kravinku v C# a narazil jsem na problém ("Sestavení smíšeného režimu je sestaveno s verzí v1.1.4322 modulu runtime a bez dalších konfiguračních údajů je nelze načíst do verze 4.0 modulu runtime.").
Vyřešil jsem ho tak, že jsem do souboru App.config napsal

<startup useLegacyV2RuntimeActivationPolicy="true">
  <supportedRuntime version="v4.0"/>
</startup>

Teď ale musím finální exe soubor posílat i se souborem apliace.exe.config jinak se nespustí.
Dá se tohle nějak vyřešit?

 
Odpovědět 24.4.2013 22:56
Avatar
Michal Žůrek (misaz):

Máš k aplikaci referencované nějaké knihovny třetích stran?

Nahoru Odpovědět 25.4.2013 15:00
Nesnáším {}, proto se jim vyhýbám.
Avatar
NEXT
Neregistrovaný
Avatar
 
Nahoru Odpovědět 25.4.2013 19:57
Avatar
Odpovídá na NEXT
Michal Žůrek (misaz):

A jsme doma :) Directx je dělán pro staré frameworky. S novými má problémy. Já vím, že mi to nejelo vůbec.

Nahoru Odpovědět 25.4.2013 19:59
Nesnáším {}, proto se jim vyhýbám.
Avatar
David Čápka
Tým ITnetwork
Avatar
Odpovídá na NEXT
David Čápka:

V čem ti vadí, že ji musíš distribuovat s configem? Dělá se to tak běžně.

Nahoru Odpovědět 25.4.2013 20:11
Miluji svou práci a zdejší komunitu, baví mě se rozvíjet, děkuji každému členovi za to, že zde působí.
Avatar
Jan Bezdíček
Redaktor
Avatar
Jan Bezdíček:

Predce jen je prijemnejsi posilat samotny .exe nez dalsich nekolik souboru (nedej boze, ze by to vyzadovalo instalaci) :D

 
Nahoru Odpovědět 25.4.2013 20:16
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 6 zpráv z 6.