Avatar
ostrozan
Redaktor
Avatar
ostrozan:

Mám takový problém:

aplikace vytvořená ve VS 2013 na PC s W7 jde setupem normálně nainstalovat na stroj s W10, nejde ale spustit - dokonce se po spuštění neděje vůbec nic - žádná hláška, chyba - nic, jako bych ani na nic neklikal.

Při tom aplikace svořená na C# expres 2010 na ntb s XPčkama - na tom samém funguje - nutno ale dodat, že byla nainstalovaná ještě před upgradem z W7 na W10.

Nejde spustit ani .exe z binu projektu - .NET 4.5 je nainstalovaný.

Nemáte někdo tušení co s tím?

 
Odpovědět 21.10.2015 15:09
Avatar
Milan Křepelka
Redaktor
Avatar
Milan Křepelka:

No tak to bude specifikum toho programu.

  • vypnout antivir
  • vypnout firewall
  • zkontrolovat jestli existují adresáře kam ten program zapisuje a jestli tam má program práva
  • spustit program jako administrátor
  • kouknout do event logu jestli negeneruje nějakou zajímavou hlášku
 
Nahoru Odpovědět 21.10.2015 18:01
Avatar
ostrozan
Redaktor
Avatar
ostrozan:

ad 1: antivir vypnut
ad 2: firewall vypnut
ad 3: adresář existuje, neexistuje -li , aplikace si ho vytvoří, při neúspěchu(nemá - li práva) vyhodí chybovou hlášku
ad 4: nejde spustit ani tak
ad 5: žádná zajímavá hláška

je to pořád stejné - po kliknutí na aplikaci, případně spuštění jako administátor se prostě neděje vůbec nic -zkoušeno na dvou ntb - jinak na XP,W7,W8 bez problémů.

Editováno 22.10.2015 19:03
 
Nahoru Odpovědět 22.10.2015 19:02
Avatar
Milan Křepelka
Redaktor
Avatar
Milan Křepelka:

Hmm. Co návaznosti na jiný SW. COM ? Taky mám W10. Jestli chceš udělám ti testovacího králíka.

 
Nahoru Odpovědět 22.10.2015 19:23
Avatar
ostrozan
Redaktor
Avatar
Odpovídá na Milan Křepelka
ostrozan:

návaznost na jiný sw není, ale připojuje se na COM port - jestli to chceš zkusit, budu rád - chceš poslat tu instalačku, nebo celý projekt?

 
Nahoru Odpovědět 22.10.2015 19:38
Avatar
Milan Křepelka
Redaktor
Avatar
Odpovídá na ostrozan
Milan Křepelka:

Pošli mi instalačku prosím.

 
Nahoru Odpovědět 23.10.2015 8:54
Avatar
Milan Křepelka
Redaktor
Avatar
Milan Křepelka:

Tak je to dobrý. Nefunguje ani jeden z nich :-). Z mého bádání mi vyplynulo, že se ten program ani nespustí. Do eventlogu to zapíše, ale na nic moc neukáše. Generuje to crashreporty. Podle mě to ukazuje na to, že nemůže natáhnout nějakou knihovnu. Click once to vypublikuje pro

x86
.NET Framework 4 Client Profile

Tedy abychom se posunuli dále, tak bych tě požádal o tři kompiláty. Už ne instaláky. Kompiláty z binu, spíš debug . Ješte jedna otázka. Pokud referencuješ nějakou knihovnu( i když jsem nic takového nenašel ani náznakem), tak ji pošli taktéž.

Pro

Any CPU
x86
x64

Pro plný FW 4.5

Akceptované řešení
+20 Zkušeností
+1 bodů
Řešení problému
 
Nahoru Odpovědět 24.10.2015 12:12
Avatar
ostrozan
Redaktor
Avatar
ostrozan:

Na vysvětlenou, proč jsem označil příspěvek jako řešení i když vlastně žádným řešením není:

Protože komunikace s Milanem probíhala na SZ a problém mi pomohl vyřešit tam - tak aspoň bodík jako poděkování.

No a aby z toho měli něco i ostatní:
Problém spočíval v tom, že při kopírování souborů z jednoho solution do druhého jsem neupravil v XAMLu cestu do složky s ikonami - takže na počítači, kde byla přítomna i ta stará složka si ji aplikace našla - problém vnikl, když se nainstalovala na jiný počítač - tam už ji samozřejmě najít nemohl - nemělo to tedy s OS a W10 co dělat.
Já konkrétně mám všechny projekty na flešce a proto mi to chodilo všude kam jsem ji vrazil.
Takže bez Milana bych na to asi nikdy nepřišel.

 
Nahoru Odpovědět  +1 27.10.2015 8:58
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 8 zpráv z 8.