Diskuze: Vkládání modelů- problém

C# .NET .NET (C# a Visual Basic) Vkládání modelů- problém American English version English version

Avatar
magic44
Redaktor
Avatar
magic44:

Ahoj, mám v Blenderu 2.6 udělanou postavičku s animacemi (prostě Armature). Tohle celé mi krásně funguje v XNA projektu :), ale chtěl jsem postavičce přidělat oblečení. To jsem udělal a aby se oblek pohyboval jako postavička, tak jsem opět udělal Armature jako rodiče (jako u postavičky). To celé hezky funguje.. v Blenderu a za tu dobu co s XNA dělám vím, že animace fungující v Blenderu skoro určitě v XNA nepůjde :).

Ano správně ani teď to nejde... XNA mi hází chybu: error normalizing vertex bone weights :/
Nevíte někdo co s tím.

Odpovědět 22.2.2014 19:44
Moudrý člověk nechce být lepší než ostatní, ale lepší, než byl sám včera.
Avatar
hanpari
Redaktor
Avatar
Odpovídá na magic44
hanpari:

Tady už to vyřešili :)

http://xboxforums.create.msdn.com/…t/18853.aspx

In fact, XNA don't allow that some vertex are not associated to a bone. To export it to be xna compliant, you need to take every vertex in the mesh and associate it to a vertex group then a bone. You shouldn't have a vertex which is not associated to a bone.

Řešení je pak dál v textu. Předpokládám, že si to z angličtiny přeložíš. Kdyby ne, dej vědět :)

 
Nahoru Odpovědět 22.2.2014 19:58
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 2 zpráv z 2.