Diskuze: IDE pro JAVA 6

Java Java IDE pro JAVA 6

Avatar
GoliathShouldWin:

Zdravím,
Mohli byste mi, prosím, někdo poradit, jakou verzi jakého IDE bych si měl stáhnout k programování v Jave 6 ? Zkoušel jsem už Eclipse a Netbeans, ale ani jeden není kompatibilní s tak starou verzí Javy, jako je "šestka". Jinou verzi ale nechci, páč se chystám Javu učit z knihy Java 6 výukový kurz od Sharona Zakhoura, která mi byla několikrát doporučena jako jedna z nejlepších.
Předem díky

 
Odpovědět 15.11.2014 22:49
Avatar
Odpovídá na GoliathShouldWin
Michal Žůrek (misaz):

stáhni cokoliv pro nejnovější 8, ono je to podobné a většina kódu z 6 by v 8 měla fungovat.

Nahoru Odpovědět 15.11.2014 23:02
Nesnáším {}, proto se jim vyhýbám.
Avatar
tomasmanhal
Člen
Avatar
Odpovídá na GoliathShouldWin
tomasmanhal:

Zvláštní. Já Java 6 Výukový kurz od Sharona mám a v NetBeans jsem jel v pohodě úplně :-)

Nahoru Odpovědět 15.11.2014 23:13
Kdyby nám dodali k životu zdrojový kód, vše by bylo jednodušší...
Avatar
GoliathShouldWin:

Chápu tě správně ? Říkáš, že mám stáhnout Javu 8 a IDE pro ni, ale programovat jako v JAVE 6, tedy podle té knihy ? :D Četl jsem, že už JAVA 7 má plno změn oproti 6 a pro Javu 8 to asi platí dvojnásob. Nebo to myslíš tak, že mám stáhnout novější IDE ? To ale, jak už jsem říkal, není kompatibilní s Javou 6. Zkoušel jsem nové verze jak Eclipsu, tak i Netbeans a ani jedno z nich s Javou 6 nefunguje.

 
Nahoru Odpovědět 15.11.2014 23:13
Avatar
GoliathShouldWin:

Ja jsem někde v archivech Oraclu našel JDK SE 6.45 a to jsem zkoušel rozjet jak na Netbeans, tak i na Eclipse, ale pokaždé mi to vyhodilo chybu kompatibility :/

 
Nahoru Odpovědět 15.11.2014 23:15
Avatar
tomasmanhal
Člen
Avatar
Odpovídá na GoliathShouldWin
tomasmanhal:

co Ti brání v tom používat jiný textový editor a kompilovat pomocí příkazáku? :-) Naučíš se být nezávislý na IDE :-)

Nahoru Odpovědět 15.11.2014 23:15
Kdyby nám dodali k životu zdrojový kód, vše by bylo jednodušší...
Avatar
GoliathShouldWin:

Dobře, díky za ochotu vás obou. Stáhnu si tedy JDK8 a k tomu Eclipse nebo NetBeans a postupně vyzkouším psát jak v editoru , tak i v IDE a dál se uvidí. Ostatně už i na jiných fórech mi doporučili pracovat s JDK 8 nebo 7, ale psát kódy pro JAVA 6, že prý i programy v JAVA 6 v JDK 7 nebo 8 v pohode pojedou.

 
Nahoru Odpovědět  +1 16.11.2014 7:43
Avatar
Atrament
Člen
Avatar
Odpovídá na GoliathShouldWin
Atrament:

Přesně jak ti radí ostatní - nainstaluj si to nejnovější, a klidně postupuj podle té knihy, Java je zpětně docela dost kompatibilní, co fungovalo v 6 většinou funguje i v novějších verzích. A u učebnice se dá čekat, že nebude používat nějaké velice speciální featury jedné konkrétní verze Javy, takže by to mohlo být v pohodě.

Pokud bys ale přece jenom trval na té verzi 6, tak v Netbeans to funguje tak, že v menu Tools - Java Platforms přidáš tu nainstalovanou verzi Javy, a pak v Projekt Properties na záložce Libraries nastavíš tu požadovanou platformu, a na záložce Sources si dole vybereš Source/Binary format JDK 6 a mělo by to fungovat v pohodě (snad jsem na nic nezapomněl).

 
Nahoru Odpovědět  +1 16.11.2014 9:44
Avatar
Chnapik2
Člen
Avatar
Chnapik2:

Podle mě není problém používat starší verzi Eclipse nebo Netbeans, případně psát v jakémkoli textovém editoru a kompilovat přes příkazový řádek. Ale verze javy by měli být zpětně kompatibilní, takže java 8 by v pohodě měla brát javu 6.

Nahoru Odpovědět 18.11.2014 20:49
Co můžeš odložit na zítřek, nedělej dnes.
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 9 zpráv z 9.