Avatar
ostrozan
Redaktor
Avatar
ostrozan:

Mám problém s Javafx - když spustím fx projekt a otevřu .java , nebo .fxml - tak se mi to tam červená jak na sjezdu ÚV KSČ a píše : Cannot resolve package, class ...... proste Cannot resolve skoro nic

Mám to nainstalované na Ubuntu - co s tím?

 
Odpovědět 20.11.2015 22:57
Avatar
Atrament
Člen
Avatar
Atrament:

A jakou Javu používáš? Nemáš tam open-jdk? Nedávno jsme tu řešili, že v open-jdk v linuxových balíčcích obvykle JavaFX není a je snad třeba doinstalovat ručně, nebude chyba v tom?

 
Nahoru Odpovědět 21.11.2015 1:21
Avatar
Jaro
Člen
Avatar
Odpovídá na ostrozan
Jaro:

Musíš doinštalovať javu fx, tá nie je defaulte v openjdk =>

sudo apt-get install openjfx
Nahoru Odpovědět 21.11.2015 7:17
A ship is safe in harbor. But then again, that´s not what ships are for.
Avatar
ostrozan
Redaktor
Avatar
Odpovídá na Jaro
ostrozan:

Javafx jsem instaloval, když jsem zkoušel NetBeans - přes plugin managera NB.
NB mi bez javafx ani nedovolil založit fx projekt - tak jsem tak nějak čekal i v IntelijIdea

 
Nahoru Odpovědět 21.11.2015 7:52
Avatar
ostrozan
Redaktor
Avatar
ostrozan:

Problém vyřešen.
Stáhl jsem si nejnovější verzi přímo z JetBrains.
Ta problémová byla z repozitáře Ubuntu.

 
Nahoru Odpovědět 2.12.2015 16:37
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 6 zpráv z 6.