Diskuze: Problém s verzí Javy

Java Java Problém s verzí Javy

Avatar
Matěj Kripner
Redaktor
Avatar
Matěj Kripner:

Zdravím,
používám Netbeans 8.0 a chci přejít na Javu 8. Stáhnul jsem si tedy tuto verzi a nastavil ji jako defaultní verzi v netbeans.conf. Problém je v tom, že některé funkce přidané v Javě 8 mi Netbeans toleruje, a u jiných říká, že ve verzi 1.7 není funkce podporována a ať si stáhnu verzi 8 nebo vyšší. Asi to půjde nějak lehce vyřešit, ale já prostě nevím :[ A už mě to fakt štve, takže budu moc rád za pomoc :)

Odpovědět 13.8.2014 19:29
"We reject kings, presidents and voting. We believe in rough consensus and running code" David Clark
Avatar
Hartrik
Redaktor
Avatar
Odpovídá na Matěj Kripner
Hartrik:

Zkus jít do Project Properties a v kategorii Sources zkontroluj Source/Binary Format.

 
Nahoru Odpovědět  +1 13.8.2014 19:35
Avatar
Matěj Kripner
Redaktor
Avatar
Odpovídá na Hartrik
Matěj Kripner:

Opravdu jsem tam měl verzi nastavenou na 1.7, díky :) Problém však zůstává i po přenastavení. Např. lambda výraz mi Netbeans v pohodě uzná, ale třeba o balíčku java.util.function prohlašuje, že neexistuje(i když mi před tím nabídl jeho použití).

Nahoru Odpovědět 13.8.2014 19:47
"We reject kings, presidents and voting. We believe in rough consensus and running code" David Clark
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 3 zpráv z 3.