Avatar
Petr Nymsa
Redaktor
Avatar
Petr Nymsa:

Zdravím, mám opět zvláštní problém. Na localhostu mi jen u jednoho webu (chápejte "složky") funguje POST. Jinde se mi REQUEST_METHOD magicky mění na GET i když posílám POST. Nějaké nápady ? Kódem to snad být nemůže. Takže někde něco v Apache ? Nevím co vše napsat a popsat. Díky za rady ! :) Nevím absolutně co s tím

Odpovědět 21.3.2014 11:43
Pokrok nezastavíš, neusni a jdi s ním vpřed
Avatar
Vojtěch Mašek (Woyta):

Je to jenom odhad, ale nomohlo by to být něco v .htaccess?

Editováno 21.3.2014 11:52
Nahoru Odpovědět 21.3.2014 11:52
Výraz "to nejde" není v mém slovníku
Avatar
Petr Nymsa
Redaktor
Avatar
Odpovídá na Vojtěch Mašek (Woyta)
Petr Nymsa:

No právě, že jeden a ten samý .httacces je v obou složkách. V jendé funguje, v jiné ne. Prostě zase něco extra a nevím co to sakra má být :`

Nahoru Odpovědět 21.3.2014 12:38
Pokrok nezastavíš, neusni a jdi s ním vpřed
Avatar
coells
Redaktor
Avatar
Odpovídá na Petr Nymsa
coells:

Zirko, GET se na POST magicky změnit nemůže, to je nesmysl (někdy si přečti specifikace, ať víš, jaký je v nich rozdíl). Takže můj odhad zní, že naprosto nemagicky posíláš GET a myslíš si, že posíláš POST.

 
Nahoru Odpovědět 21.3.2014 12:38
Avatar
Petr Nymsa
Redaktor
Avatar
Odpovídá na coells
Petr Nymsa:

Ne, vím co je GET, vím co je POST. Ukážu screen, opravdu se mi změní požadavek. Nevím proč, jestli to je tím klientem který komunikuje s API ale vše fungovalo. Jenom jsem změnil složku a cca 2 řádky a náhle se mi POST mění na GET. PUT, DELETE vše funguje

Nahoru Odpovědět 21.3.2014 12:40
Pokrok nezastavíš, neusni a jdi s ním vpřed
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 6 zpráv z 6.