Diskuze: nette 2.4

PHP Nette Framework Nette framework nette 2.4

Avatar
Milan Gallas
Redaktor
Avatar
Milan Gallas:

Ahoj nedaří se mi nainstalovat nejnovější nette. Nevíte čím to může být?
chyba:

PS C:\xampp\htdocs\nette\app-template> composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install nette/nette 2.4.x-dev
    - Conclusion: remove ublaboo/datagrid v3.3.1
    - Conclusion: don't install nette/utils 2.4.x-dev
    - Conclusion: don't install ublaboo/datagrid v3.3.1
    - Conclusion: don't install nette/utils v2.4.0
    - Installation request for nette/nette ~2.4.0 -> satisfiable by nette/nette[2.4.x-dev, v2.4.0].
    - ublaboo/datagrid v3.3.0 requires nette/utils ~2.3.0 -> satisfiable by nette/utils[v2.3.10, v2.3.0, v2.3.1, v2.3.2
 v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.3.x-dev].
    - ublaboo/datagrid v3.2.0 requires nette/utils ~2.3.0 -> satisfiable by nette/utils[v2.3.10, v2.3.0, v2.3.1, v2.3.2
 v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.3.x-dev].
    - ublaboo/datagrid v3.1.7 requires nette/utils ~2.3.0 -> satisfiable by nette/utils[v2.3.10, v2.3.0, v2.3.1, v2.3.2
 v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.3.x-dev].
    - ublaboo/datagrid v3.1.6 requires nette/utils ~2.3.0 -> satisfiable by nette/utils[v2.3.10, v2.3.0, v2.3.1, v2.3.2
 v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.3.x-dev].
    - ublaboo/datagrid v3.1.5 requires nette/utils ~2.3.0 -> satisfiable by nette/utils[v2.3.10, v2.3.0, v2.3.1, v2.3.2
 v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.3.x-dev].
    - ublaboo/datagrid v3.1.4 requires nette/utils ~2.3.0 -> satisfiable by nette/utils[v2.3.10, v2.3.0, v2.3.1, v2.3.2
 v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.3.x-dev].
    - ublaboo/datagrid v3.1.3 requires nette/utils ~2.3.0 -> satisfiable by nette/utils[v2.3.10, v2.3.0, v2.3.1, v2.3.2
 v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.3.x-dev].
    - ublaboo/datagrid v3.1.2 requires nette/utils ~2.3.0 -> satisfiable by nette/utils[v2.3.10, v2.3.0, v2.3.1, v2.3.2
 v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.3.x-dev].
    - ublaboo/datagrid v3.1.1 requires nette/utils ~2.3.0 -> satisfiable by nette/utils[v2.3.10, v2.3.0, v2.3.1, v2.3.2
 v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.3.x-dev].
    - ublaboo/datagrid v3.1.0 requires nette/utils ~2.3.0 -> satisfiable by nette/utils[v2.3.10, v2.3.0, v2.3.1, v2.3.2
 v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.3.x-dev].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.10].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.5].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.6].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.7].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.8].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.9].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.x-dev].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.0].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.1].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.2].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.3].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.4].
    - Can only install one of: nette/utils[v2.4.0-RC1, v2.3.10].
    - nette/nette v2.4.0 requires nette/utils ^2.4 -> satisfiable by nette/utils[2.4.x-dev, v2.4.0, v2.4.0-RC1, v2.4.0-
C2].
    - Conclusion: don't install nette/utils v2.4.0-RC2
    - Installation request for ublaboo/datagrid ^3.1 -> satisfiable by ublaboo/datagrid[v3.1.0, v3.1.1, v3.1.2, v3.1.3,
v3.1.4, v3.1.5, v3.1.6, v3.1.7, v3.2.0, v3.3.0, v3.3.1].

composer.json

{
        .........

    "minimum-stability": "dev",
        "require": {
                "php": ">= 5.5.0",
        "nette/nette": "~2.4.0",
        "dg/adminer-custom": "dev-master as 2.3-dev",
                "kdyby/doctrine": "~3.1.0",
                "kdyby/translation": "^2.2",
                "carrooi/nette-menu": "^1.1",
                "ublaboo/datagrid": "^3.1",
                "drahak/restful": "@dev",
                "nittro/nette-bridges": "1.0.0"
        },
        "require-dev": {
                "nette/tester": "2.0.x-dev"
        }
}
 
Odpovědět 22. června 13:19
Avatar
Milan Gallas
Redaktor
Avatar
Milan Gallas:

Tak vyřešeno chyba byla u :
"ublaboo/datagrid": "^3.1"

 
Nahoru Odpovědět 22. června 13:52
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 2 zpráv z 2.