Pouze tento týden sleva až 80 % na e-learning týkající se Javy. Zároveň využij akce až 50 % zdarma při nákupu e-learningu - více informací.
Hledáme nové posily do ITnetwork týmu. Podívej se na volné pozice a přidej se do nejagilnější firmy na trhu - Více informací.
discount 50 + hiring
Avatar
Michal Hadraba:2.11.2020 23:54

Zdravím,
Lze na VS přidat konfiguraci pro jednu architekturu procesoru 2x? Potřebuji provozovat (kompilovat) aplikaci jak na VS2017, tak na VS2015, kvůli zpětné kompatibilitě. Potřeboval bych mít kromě x64 třeba ještě x64-2015. Problém je, že při vytváření nové konfigurace mi to už znovu výběr x64 nenabídne.
Je nějaká cesta?
Nebo je jiná metoda jak změnit některá nastavení kompilatoru. Potřebuji třeba změnit cestu ke knihovnám (typicky třeba cesty k obj a include adresarum).
Dík.

Zkusil jsem: Zkoušel jsem to editovat přímo v sln/vlx souboru, ale to myslím nevedlo tím správným směrem.

Chci docílit: Mám aplikaci pro Autocad, takový plugin. Knihovna autocadu (SDK object ARX) má různé verze a ty potřebuji různé knihovny (respektive include a object soubory různých verzí) . Pro Acad 2018 existuje arx 2018, pro Acad 2020 ARX 2020...atd. A 2018 vyžaduje nižší verzi MFC než 2020.

 
Odpovědět
2.11.2020 23:54
Avatar
JerryM
Člen
Avatar
JerryM:8.11.2020 15:05

pro jazyky jako je C++ nebo C++/CLI to jde .. ale musíš si stáhnout příslušnou compilační platformu ...
tzv. BuildTools

Microsoft Build Tools 2013 (v120 tools) https://www.microsoft.com/…details.aspx?…
Microsoft Build Tools 2015 https://www.microsoft.com/…details.aspx?…
Build Tools for Visual Studio 2017 https://visualstudio.microsoft.com/downloads/#…

jestli to de i pro C# to nevim

Akceptované řešení
+20 Zkušeností
+1 bodů
Řešení problému
 
Nahoru Odpovědět
8.11.2020 15:05
Avatar
Odpovídá na JerryM
Michal Hadraba:9.11.2020 9:34

Díky,
no a když to nainstaluju, tak dál co? V Properties MSVS 2017 se mi další verze neobjevila, je tam stále jen v141 a 140.

 
Nahoru Odpovědět
9.11.2020 9:34
Avatar
JerryM
Člen
Avatar
JerryM:9.11.2020 10:23

v tom případě si nainstalvoal něco špatně protože jak mužeš vidět tady na tom obrázku:
https://uloz.to/…Jl/tools-bmp
mě to funguje a mám MSVS2019...

https://superuser.com/…-build-tools

jenom nezapomeň, že v MS VS 2017 nenainstaluješ novější BuildTools pro verzi 2019 ...
jenom pro starší verze

taky pevně věřím žemáš nainstalovanej SoftwareDevelop­mentKit pro ty starší verze přes instalátor MS VS 2017 musí se to tam zaškrtnout

 
Nahoru Odpovědět
9.11.2020 10:23
Avatar
Odpovídá na JerryM
Michal Hadraba:9.11.2020 16:35

Mám nainstalovanej SDK kit pro VS 2015, ten funguje normálně, bez toho, aniž bych cokoli doinstaloval. Pak jsou tam k dispozici mraky verzí Win10, tak ty nainstalovaný nemám, a jinak tam nic k výběru není.
Mám VS2017.
(to, že nejde 2019 pro VS 2017 je jasný). Chci VS 2013...

Dík za trpělivost.

 
Nahoru Odpovědět
9.11.2020 16:35
Avatar
JerryM
Člen
Avatar
JerryM:9.11.2020 17:41

zkusil si tohle ?
https://www.microsoft.com/…details.aspx?…
https://stackoverflow.com/…ory/48851425

možná by bylo lepší nainstalvoat si MS VS 2013 ..

 
Nahoru Odpovědět
9.11.2020 17:41
Avatar
JerryM
Člen
Avatar
 
Nahoru Odpovědět
9.11.2020 17:44
Avatar
JerryM
Člen
Avatar
JerryM:9.11.2020 17:49

tady je BuildTools pro MS VS 2013
https://uloz.to/…ols-2013-rar

 
Nahoru Odpovědět
9.11.2020 17:49
Avatar
JerryM
Člen
Avatar
JerryM:9.11.2020 17:52

nechceš si radši nainstalovat MS VS 2019 ????

 
Nahoru Odpovědět
9.11.2020 17:52
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 10 zpráv z 10.