Využij akce až 30 % zdarma při nákupu e-learningu. Více informací. Zároveň je tento týden sleva až 80 % na e-learning týkající se C# .NET
Hledáme nového kolegu do redakce - 100% home office, 100% flexibilní pracovní doba. Více informací.
discount week 30 halloween
Avatar
Jan Voženílek
Redaktor
Avatar
Jan Voženílek:28. září 13:35

S kamarádem dělám módovaný server, ale nedokážu najít Forge 1.12.2 (14.23.4.2766). Kdyby někdo věděl, jak to stáhnout, byl bych rád.
Děkuji

 
Odpovědět
28. září 13:35
Avatar
Jan Kerhart
Člen
Avatar
Jan Kerhart:28. září 21:54

Ahoj,
a zkoušel jsi ho vůbec hledat? Vždyť i přímo zmíněná verze 14.23.4.2766 je normálně ke stažení na oficiálních stránkách Forge v sekci soubory > 1.12.2.

Zde je přímý odkaz na 14.23.4.2766 installer.

 
Nahoru Odpovědět
28. září 21:54
Tento výukový obsah pomáhají rozvíjet následující firmy, které dost možná hledají právě tebe!
Avatar
Jan Voženílek
Redaktor
Avatar
Odpovídá na Jan Kerhart
Jan Voženílek:29. září 15:13

No to jo, jenomže tenhle je nefunkční. Tohle vyhodí:

java.net.preferIPv4Stack=true
Exception in thread "main" java.lang.reflect.InvocationTargetException
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:564)
        at net.minecraftforge.installer.Java6Gate.main(Java6Gate.java:48)
Caused by: java.lang.ExceptionInInitializerError
        at net.minecraftforge.installer.ClientInstall.getSponsorMessage(ClientInstall.java:401)
        at net.minecraftforge.installer.InstallerAction.getSponsorMessage(InstallerAction.java:60)
        at net.minecraftforge.installer.InstallerPanel.updateFilePath(InstallerPanel.java:334)
        at net.minecraftforge.installer.InstallerPanel.<init>(InstallerPanel.java:315)
        at net.minecraftforge.installer.SimpleInstaller.launchGui(SimpleInstaller.java:167)
        at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:54)
        ... 5 more
Caused by: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1
        at net.minecraftforge.installer.MirrorData.buildMirrorList(MirrorData.java:84)
        at net.minecraftforge.installer.MirrorData.<init>(MirrorData.java:63)
        at net.minecraftforge.installer.MirrorData.<clinit>(MirrorData.java:17)
        ... 11 more
 
Nahoru Odpovědět
29. září 15:13
Avatar
Jan Kerhart
Člen
Avatar
Odpovídá na Jan Voženílek
Jan Kerhart:30. září 19:50

Ahoj,
no, otázka zněla, kde ho stáhnout, ne proč nejde spustit :D Tohle není tím, že by ten soubor by poškozen, ale danou verzí installeru jako takovou. Problém je tam v tom, že nedávno Forge provedl nějaké migrace svých serverů a staré instalátory obsahují staré, neplatné odkazy. Poslední verze Forge pro každou verzi MC by měly být již upraveny, oprava ostatních bude také, ale v současnosti to není prioritní problém... :)

Proč potřebuješ přesně verzi 14.23.4.2766? Pokud k tomu není žádný specifický důvod, tak doporučuju použít nejnovější verzi pro MC 1.12.2, tj. 14.23.5.2855, ta funguje. Pokud opravdu potřebuješ verzi 14.23.4.2766, tak jediná možnost je nainstalovat ji ručně pomocí universal jaru. Ale tam budeš muset ručně stáhnout všechny potřebné knihovny (je jich cca 20) a dát je do složky libraries...

 
Nahoru Odpovědět
30. září 19:50
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 4 zpráv z 4.