Vydělávej až 160.000 Kč měsíčně! Akreditované rekvalifikační kurzy s garancí práce od 0 Kč. Více informací.
Hledáme nové posily do ITnetwork týmu. Podívej se na volné pozice a přidej se do nejagilnější firmy na trhu - Více informací.

Diskuze: EXCEL - DATUM - +24 h

Aktivity
Avatar
pokusnicek
Člen
Avatar
pokusnicek:24.7.2018 13:46

Ahoj,
Nevím, jakou funkci použít, abych měl den, měsíc, rok, hodinu v jedné bunce a pak v druhé den, mesic, rok,(o 1 den navíc) a hodina by byla stejná

Zkusil jsem: Zkoušel jsem funkci =DNES() + 1
Tím dostanu o den navíc. Ale bojím se, aby se každý den datum neaktualizoval na ten daný.

Čili myslím to tak, že
Napíšu =DNES() -> dostanu 24.7
Napíšu =DNES() +1 -> dostanu 25.7

Ale nechci abych kdybych to otevřel třeba zítra, aby se z 24.7 to přepsalo na 25.7

Chci docílit: Snažím se dosáhnout toho, aby když napíšu do jednoho sloupce datum dnešní + aktuální hodinu, aby mi do další bunky napsalo o den navíc s tou samou hodinou.

Editováno 24.7.2018 13:46
 
Odpovědět
24.7.2018 13:46
Avatar
Daniel Zábojník:24.7.2018 14:44

Ahoj, musíš si nastavit formát buňky na Vlastní a jako typ vybrat dd.mm.rrrr h:mm. Pak už jen stačí napsat například do buňky A1 požadovaný datum a čas. Následně do další vybrané buňky napsat vzorec =$A$1+1 . Řešení také lze stáhnout na tomto odkazu. Snad jsem dotaz pochopil správně a pomohl ti. :)

 
Nahoru Odpovědět
24.7.2018 14:44
Avatar
pokusnicek
Člen
Avatar
Odpovídá na Daniel Zábojník
pokusnicek:25.7.2018 9:21

A šlo by automaticky?
že bych do jedné bunky napsal datum a čas a v druhé se automaticky zvednul o jedničku? :)

 
Nahoru Odpovědět
25.7.2018 9:21
Avatar
Odpovídá na pokusnicek
Daniel Zábojník:25.7.2018 9:27

Vždyť je to automatické. Po zadání se datum a čas v druhé buňce automaticky změní.

 
Nahoru Odpovědět
25.7.2018 9:27
Avatar
pokusnicek
Člen
Avatar
pokusnicek:25.7.2018 9:46

Zkusil jsem přes funkci KDYŽ, ale to mi nějak nejde:D

 
Nahoru Odpovědět
25.7.2018 9:46
Avatar
pokusnicek
Člen
Avatar
Odpovídá na Daniel Zábojník
pokusnicek:25.7.2018 9:48

Jej,

promin, já to špatně vysvětlil. :)

Můj požadavek je:

Mám 50 pozic, potřebuji u každé pozice kolonku, začátek testu a konec testu. Na každé pozici je začátek testu jiný. Potřebuji:
Př: Do Bunky A1 zadat datum no a v bunce B1 aby se zvýšil o 1 a nebo by se napsalo: Nebyl zadán začátek testu. (Nebyla vyplněna hodnota A1)

Díky :)

 
Nahoru Odpovědět
25.7.2018 9:48
Avatar
Odpovídá na pokusnicek
Michal Štěpánek:25.7.2018 9:58

Do buňky A1 dáš datum, např.:

25.7.2018 10:00

do buňky B1 dáš vzoreček

=KDYŽ(A1 <> ""; A1+1;"NIC")
Editováno 25.7.2018 9:59
Nahoru Odpovědět
25.7.2018 9:58
Nikdy neříkej nahlas, že to nejde. Vždycky se totiž najde blbec, který to neví a udělá to...
Avatar
Odpovídá na pokusnicek
Daniel Zábojník:25.7.2018 10:01

Už rozumím, napiš si tedy do buňky A1 datum a čas. A do B1 vlož vzorec:

=KDYŽ(JE.PRÁZDNÉ($A1);"Nebyl zadán začátek testu!";$A1+1)

Následně můžeš vzorec "roztáhnout" na 50 řádků o kterých jsi psal.

Editováno 25.7.2018 10:02
 
Nahoru Odpovědět
25.7.2018 10:01
Avatar
Odpovídá na Daniel Zábojník
Michal Štěpánek:25.7.2018 10:10

Jen ten dolar ($) na konci by tam asi neměl být

=KDYŽ(JE.PRÁZDNÉ($A1);"Nebyl zadán začátek testu!";A1+1)

protože jinak to do ostatních buňěk vyplní stejné hodnoty jako v B1

Nahoru Odpovědět
25.7.2018 10:10
Nikdy neříkej nahlas, že to nejde. Vždycky se totiž najde blbec, který to neví a udělá to...
Avatar
pokusnicek
Člen
Avatar
Odpovídá na Michal Štěpánek
pokusnicek:25.7.2018 10:28

Dobře, děkuji Vám. Zkusím to a ozvu se:)

Editováno 25.7.2018 10:29
 
Nahoru Odpovědět
25.7.2018 10:28
Avatar
Odpovídá na pokusnicek
Michal Štěpánek:25.7.2018 10:31

Zapiš to úplně stejně jak to vidíš v příspěvku (pokud tedy nemáš anglické Office).

=KDYŽ(JE.PRÁZDNÉ($A1);"Nebyl zadán začátek testu!";A1+1)

nebo můžeš použít starší zápis

=KDYŽ(A1<>""; A1+1;"Nebyl zadán začátek testu!")
Editováno 25.7.2018 10:31
Akceptované řešení
+20 Zkušeností
+2,50 Kč
Řešení problému
Nahoru Odpovědět
25.7.2018 10:31
Nikdy neříkej nahlas, že to nejde. Vždycky se totiž najde blbec, který to neví a udělá to...
Avatar
Odpovídá na Michal Štěpánek
Daniel Zábojník:25.7.2018 10:32

Máš pravdu, tohle jsem přehlédl. Dolar na konci být nemá. Díky za opravu :)

 
Nahoru Odpovědět
25.7.2018 10:32
Avatar
Odpovídá na pokusnicek
Daniel Zábojník:25.7.2018 10:36

Pokud máš anglické Office, vzorec bude vypadat takto:

=IF(ISBLANK($A1);"Nebyl zadán začátek testu!";A1+1)
 
Nahoru Odpovědět
25.7.2018 10:36
Avatar
pokusnicek
Člen
Avatar
Odpovídá na Daniel Zábojník
pokusnicek:26.7.2018 11:11

přesně takhle jsem to zadal a výsledek = špatná hodnota.. :(

 
Nahoru Odpovědět
26.7.2018 11:11
Avatar
pokusnicek
Člen
Avatar
Odpovídá na Daniel Zábojník
pokusnicek:26.7.2018 11:17

Respektivě v českých office to jde, v EN nejde. :D

 
Nahoru Odpovědět
26.7.2018 11:17
Avatar
Odpovídá na pokusnicek
Michal Štěpánek:26.7.2018 13:59

ani takto?

=IF(IS.BLANK($A1);"Nebyl zadán začátek testu!";A1+1)
Nahoru Odpovědět
26.7.2018 13:59
Nikdy neříkej nahlas, že to nejde. Vždycky se totiž najde blbec, který to neví a udělá to...
Avatar
Odpovídá na Michal Štěpánek
Daniel Zábojník:26.7.2018 19:26

Funkce IS.BLANK() neexistuje, Excel mi nabízí jen ISBLANK().

 
Nahoru Odpovědět
26.7.2018 19:26
Avatar
Odpovídá na Daniel Zábojník
Michal Štěpánek:26.7.2018 19:38

Jj, taky jsem si pak všiml...

Nahoru Odpovědět
26.7.2018 19:38
Nikdy neříkej nahlas, že to nejde. Vždycky se totiž najde blbec, který to neví a udělá to...
Avatar
pokusnicek
Člen
Avatar
Odpovídá na Michal Štěpánek
pokusnicek:27.7.2018 14:48

Celý problém je ve formátu buněk, to co jsem tady od Vás použil funguje v CZ, ale ne v EN verzi. :)

 
Nahoru Odpovědět
27.7.2018 14:48
Avatar
pokusnicek
Člen
Avatar
Odpovídá na Daniel Zábojník
pokusnicek:27.7.2018 14:54

Mám to hotové. Děkuji.

 
Nahoru Odpovědět
27.7.2018 14:54
Avatar
Odpovídá na pokusnicek
Daniel Zábojník:27.7.2018 15:05

Tak to je super, označ ještě řešení v této diskuzi. Děkuji

 
Nahoru Odpovědět
27.7.2018 15:05
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 21 zpráv z 21.