Diskuze: EXCEL - DATUM - +24 h

Windows Windows EXCEL - DATUM - +24 h

Aktivity (1)
Avatar
Kejmou
Člen
Avatar
Kejmou:24. července 13:46

Ahoj,
Nevím, jakou funkci použít, abych měl den, měsíc, rok, hodinu v jedné bunce a pak v druhé den, mesic, rok,(o 1 den navíc) a hodina by byla stejná

Zkusil jsem: Zkoušel jsem funkci =DNES() + 1
Tím dostanu o den navíc. Ale bojím se, aby se každý den datum neaktualizoval na ten daný.

Čili myslím to tak, že
Napíšu =DNES() -> dostanu 24.7
Napíšu =DNES() +1 -> dostanu 25.7

Ale nechci abych kdybych to otevřel třeba zítra, aby se z 24.7 to přepsalo na 25.7

Chci docílit: Snažím se dosáhnout toho, aby když napíšu do jednoho sloupce datum dnešní + aktuální hodinu, aby mi do další bunky napsalo o den navíc s tou samou hodinou.

Editováno 24. července 13:46
 
Odpovědět 24. července 13:46
Avatar
Daniel Zábojník:24. července 14:44

Ahoj, musíš si nastavit formát buňky na Vlastní a jako typ vybrat dd.mm.rrrr h:mm. Pak už jen stačí napsat například do buňky A1 požadovaný datum a čas. Následně do další vybrané buňky napsat vzorec =$A$1+1 . Řešení také lze stáhnout na tomto odkazu. Snad jsem dotaz pochopil správně a pomohl ti. :)

Nahoru Odpovědět 24. července 14:44
Nesnáším psaní { } ale bohužel jsou potřeba a vyhnout se jim nejde!
Avatar
Kejmou
Člen
Avatar
Odpovídá na Daniel Zábojník
Kejmou:25. července 9:21

A šlo by automaticky?
že bych do jedné bunky napsal datum a čas a v druhé se automaticky zvednul o jedničku? :)

 
Nahoru Odpovědět 25. července 9:21
Avatar
Odpovídá na Kejmou
Daniel Zábojník:25. července 9:27

Vždyť je to automatické. Po zadání se datum a čas v druhé buňce automaticky změní.

Nahoru Odpovědět 25. července 9:27
Nesnáším psaní { } ale bohužel jsou potřeba a vyhnout se jim nejde!
Avatar
Kejmou
Člen
Avatar
Kejmou:25. července 9:46

Zkusil jsem přes funkci KDYŽ, ale to mi nějak nejde:D

 
Nahoru Odpovědět 25. července 9:46
Avatar
Kejmou
Člen
Avatar
Odpovídá na Daniel Zábojník
Kejmou:25. července 9:48

Jej,

promin, já to špatně vysvětlil. :)

Můj požadavek je:

Mám 50 pozic, potřebuji u každé pozice kolonku, začátek testu a konec testu. Na každé pozici je začátek testu jiný. Potřebuji:
Př: Do Bunky A1 zadat datum no a v bunce B1 aby se zvýšil o 1 a nebo by se napsalo: Nebyl zadán začátek testu. (Nebyla vyplněna hodnota A1)

Díky :)

 
Nahoru Odpovědět 25. července 9:48
Avatar
Odpovídá na Kejmou
Michal Štěpánek:25. července 9:58

Do buňky A1 dáš datum, např.:

25.7.2018 10:00

do buňky B1 dáš vzoreček

=KDYŽ(A1 <> ""; A1+1;"NIC")
Editováno 25. července 9:59
Nahoru Odpovědět 25. července 9:58
Nikdy neříkej nahlas, že to nejde. Vždycky se totiž najde blbec, který to neví a udělá to...
Avatar
Odpovídá na Kejmou
Daniel Zábojník:25. července 10:01

Už rozumím, napiš si tedy do buňky A1 datum a čas. A do B1 vlož vzorec:

=KDYŽ(JE.PRÁZDNÉ($A1);"Nebyl zadán začátek testu!";$A1+1)

Následně můžeš vzorec "roztáhnout" na 50 řádků o kterých jsi psal.

Editováno 25. července 10:02
Nahoru Odpovědět 25. července 10:01
Nesnáším psaní { } ale bohužel jsou potřeba a vyhnout se jim nejde!
Avatar
Odpovídá na Daniel Zábojník
Michal Štěpánek:25. července 10:10

Jen ten dolar ($) na konci by tam asi neměl být

=KDYŽ(JE.PRÁZDNÉ($A1);"Nebyl zadán začátek testu!";A1+1)

protože jinak to do ostatních buňěk vyplní stejné hodnoty jako v B1

Nahoru Odpovědět 25. července 10:10
Nikdy neříkej nahlas, že to nejde. Vždycky se totiž najde blbec, který to neví a udělá to...
Avatar
Kejmou
Člen
Avatar
Odpovídá na Michal Štěpánek
Kejmou:25. července 10:28

Dobře, děkuji Vám. Zkusím to a ozvu se:)

Editováno 25. července 10:29
 
Nahoru Odpovědět 25. července 10:28
Avatar
Odpovídá na Kejmou
Michal Štěpánek:25. července 10:31

Zapiš to úplně stejně jak to vidíš v příspěvku (pokud tedy nemáš anglické Office).

=KDYŽ(JE.PRÁZDNÉ($A1);"Nebyl zadán začátek testu!";A1+1)

nebo můžeš použít starší zápis

=KDYŽ(A1<>""; A1+1;"Nebyl zadán začátek testu!")
Editováno 25. července 10:31
Akceptované řešení
+20 Zkušeností
+1 bodů
Řešení problému
Nahoru Odpovědět 25. července 10:31
Nikdy neříkej nahlas, že to nejde. Vždycky se totiž najde blbec, který to neví a udělá to...
Avatar
Odpovídá na Michal Štěpánek
Daniel Zábojník:25. července 10:32

Máš pravdu, tohle jsem přehlédl. Dolar na konci být nemá. Díky za opravu :)

Nahoru Odpovědět  +1 25. července 10:32
Nesnáším psaní { } ale bohužel jsou potřeba a vyhnout se jim nejde!
Avatar
Odpovídá na Kejmou
Daniel Zábojník:25. července 10:36

Pokud máš anglické Office, vzorec bude vypadat takto:

=IF(ISBLANK($A1);"Nebyl zadán začátek testu!";A1+1)
Nahoru Odpovědět 25. července 10:36
Nesnáším psaní { } ale bohužel jsou potřeba a vyhnout se jim nejde!
Avatar
Kejmou
Člen
Avatar
Odpovídá na Daniel Zábojník
Kejmou:26. července 11:11

přesně takhle jsem to zadal a výsledek = špatná hodnota.. :(

 
Nahoru Odpovědět 26. července 11:11
Avatar
Kejmou
Člen
Avatar
Odpovídá na Daniel Zábojník
Kejmou:26. července 11:17

Respektivě v českých office to jde, v EN nejde. :D

 
Nahoru Odpovědět 26. července 11:17
Avatar
Odpovídá na Kejmou
Michal Štěpánek:26. července 13:59

ani takto?

=IF(IS.BLANK($A1);"Nebyl zadán začátek testu!";A1+1)
Nahoru Odpovědět 26. července 13:59
Nikdy neříkej nahlas, že to nejde. Vždycky se totiž najde blbec, který to neví a udělá to...
Avatar
Odpovídá na Michal Štěpánek
Daniel Zábojník:26. července 19:26

Funkce IS.BLANK() neexistuje, Excel mi nabízí jen ISBLANK().

Nahoru Odpovědět  +1 26. července 19:26
Nesnáším psaní { } ale bohužel jsou potřeba a vyhnout se jim nejde!
Avatar
Odpovídá na Daniel Zábojník
Michal Štěpánek:26. července 19:38

Jj, taky jsem si pak všiml...

Nahoru Odpovědět 26. července 19:38
Nikdy neříkej nahlas, že to nejde. Vždycky se totiž najde blbec, který to neví a udělá to...
Avatar
Kejmou
Člen
Avatar
Odpovídá na Michal Štěpánek
Kejmou:27. července 14:48

Celý problém je ve formátu buněk, to co jsem tady od Vás použil funguje v CZ, ale ne v EN verzi. :)

 
Nahoru Odpovědět 27. července 14:48
Avatar
Kejmou
Člen
Avatar
Odpovídá na Daniel Zábojník
Kejmou:27. července 14:54

Mám to hotové. Děkuji.

 
Nahoru Odpovědět 27. července 14:54
Avatar
Odpovídá na Kejmou
Daniel Zábojník:27. července 15:05

Tak to je super, označ ještě řešení v této diskuzi. Děkuji

Nahoru Odpovědět 27. července 15:05
Nesnáším psaní { } ale bohužel jsou potřeba a vyhnout se jim nejde!
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 21 zpráv z 21.