Avatar
Lukáš Krejčí:14.4.2019 11:59

Ahoj, nejde mi spustit Eclipse, stáhnul jsem si verzi eclipse-java-kepler-SR1-win32-x86_64 (pro 64-bit Win 10 systém) a mám nainstalovaný JAVA Java SE Development Kit 11.0.2 (zkoušel jsem i nejnovější verzi SE 12 ale výsledek stejný).
Po spuštění mi blikne logo Eclipse a hodí mi to error, když mrknu do error logu, takje tam dost informací, ale hlavně toto:
MESSAGE Startup error
!STACK 1
java.lang.Run­timeException: Exception in org.eclipse.os­gi.framework.in­ternal.core.Sys­temBundleActi­vator.start() of bundle org.eclipse.osgi.

atd.

Nemáte s tím někdo zkušenosti pls? Teoreticky to vypadá na problém s verzemi, ale mám jak Eclipse tak JAVU pro 64 bit.
Nemůže být konflikt s Javou, kterou mám na kompu nainstalovanou z dřívějška, t.j. jre1.8.0_192?

Předem moc díky

Zkusil jsem: Reinstalace JAVY z verze JAVA Java SE Development Kit 12 na JAVA Java SE Development Kit 11.0.2.

 
Odpovědět
14.4.2019 11:59
Avatar
Virlupus
Redaktor
Avatar
Virlupus:14.4.2019 23:40

Pokud mohu doporučit, tak si stáhni Java 8. Jinak ti to fakt nepojede. Zatím, žádný z programů není dělaný pro vyšší verzi.... tedy pokud vím

 
Nahoru Odpovědět
14.4.2019 23:40
Avatar
Virlupus
Redaktor
Avatar
Odpovídá na Lukáš Krejčí
Virlupus:14.4.2019 23:42

Pardon. Zapomněl jsem dodat verzi SKD a nikoli JRE.

 
Nahoru Odpovědět
14.4.2019 23:42
Tento výukový obsah pomáhají rozvíjet následující firmy, které dost možná hledají právě tebe!
Avatar
Virlupus
Redaktor
Avatar
Odpovídá na Virlupus
Virlupus:14.4.2019 23:55

Omluva JDK -- Java Development Kit

 
Nahoru Odpovědět
14.4.2019 23:55
Avatar
Odpovídá na Virlupus
Robert Michalovič:15.4.2019 10:46

2virlupus.soft : Java 9,10,11 (Oracle Java, Open Java) jsou podporované spousty IDE a to vč. i nižších verzí Javy (mimochodem není vhodné psát své neověřené domněnky)
např.
Eclipse 09-2018 podporuje Java9,10
Eclipse 12-2018 podporuje Java9,10,11
Eclipse 03-2019 podporuje Java9,10,11, možná 12

NetBeans 8 podporuje Java 8
Apache NetBeans podporuje Java ..,6,7,8,9,10,11 a možná i Java12 https://netbeans.apache.org/…0/index.html

a to neřeším ani IntelliIDEA (https://www.jetbrains.com/idea/ )

2Lukáš Krejčí : Skutečně je velmi brilantní nápad zkoušet Eclipse "Kepler "z roku 2013 z éry Java7, rozchodit s Java 12 ( vyšlo 03/2019),11(vyšlo 09/2018),8 (rok 2015). (https://en.wikipedia.org/…se_(software))

Takže pokud chceš Javu 8,9,10,11 tak si stáhni aktuální Eclipse 12-2018 a né z roku 2013 nebo použij jiné IDE. Jinak pokud chceš použít tuto konkrétní verzi IDE pak musíš použít max. Java 7. Zde na webu najdeš spoustu tutoriálů jak rozchodit Eclipse. Ke spuštění je nutno pouze mít nastavenou systémovou proměnnou PATH na OS.

https://www.itnetwork.cz/…ova-aplikace
https://www.itnetwork.cz/…-eclipse-ide
https://www.itnetwork.cz/…adku-zaklady

 
Nahoru Odpovědět
15.4.2019 10:46
Avatar
Lubor Pešek
Člen
Avatar
Lubor Pešek:15.4.2019 14:18

Jen doplním - NB 10 taky jede na JDK 11. To samé i Maven, IDEA a spousta dalších aplikací. Takže tvrzení, že ji nepoužívají žádné aplikace je fakt přehnané.
To, že České firmy mají projekty v javě 8 není ani tak dáno touto verzí, jako spíš enterprise technologiemi.
Přeci jen není tak lehké přecházet z verze na verzi Springu, jako u obyčejných SE aplikací:)

Nahoru Odpovědět
15.4.2019 14:18
Existují dva způsoby, jak vyřešit problém. Za prvé vyhoďte počítač z okna. Za druhé vyhoďte okna z počítače.
Děláme co je v našich silách, aby byly zdejší diskuze co nejkvalitnější. Proto do nich také mohou přispívat pouze registrovaní členové. Pro zapojení do diskuze se přihlas. Pokud ještě nemáš účet, zaregistruj se, je to zdarma.

Zobrazeno 7 zpráv z 7.