Aktuálně: Postihly zákazy tvou profesi? Poptávka po ajťácích prudce roste, využij slevové akce 30% výuky zdarma!
Hledáme fulltime PHP programátora do ITnetwork týmu - 100% homeoffice, 100% časově flexibilní #bezdeadlinu Mám zájem!

Lekce 9 - Vzorce, funkce a adresování v aplikaci Excel 3

V minulé lekci, Vzorce, funkce a adresování v aplikaci Excel 2, jsme si ukázali relativní adresování, hromadné výpočty, smíšené adresování a argumenty funkcí. Tato třetí lekce v minisérii o vzorcích, odkazech a adresování představí dosud nepopsané zajímavé možnosti využití funkcí.

Vnořování funkcí

Kolik funkcí se vejde do jedné buňky? Správná odpověď je opět nekonečno, nebo něco podobného, a to z toho důvodu, že funkce můžeme do sebe vzájemně vnořovat, a pak se hodnota vnořené (vnitřní) funkce stává argumentem funkce vnější.

Mezi jednodušší příklady patří třeba tento způsob součtu hodnot v buňkách:

=SUMA(SUMA(A1:A2);SUMA(A3:A4)). Tento výpočet můžeme označit jako „sumu sum“, kdy se nejprve vyhodnotí dva vnitřní součty a ty se pak navzájem sečtou. Opět se bavíme čistě akademicky, protože toto je dost nepraktické.

Jiná je situace s funkcí KDYŽ, která je učebnicovou funkcí pro vnořování. Platí totiž, že jedna funkce KDYŽ může pojmout jen jedno kritérium (podmínku), a to je mnohdy nedostatečné. Třeba když si řekneme, že voda pod 0°C je ve formě ledu a nad 100°C je ve formě páry. Jak bychom toto převedli do řeči Excelu?

Potřebujeme funkci KDYŽ do sebe vzájemně vnořit. Platí, že **počet intervalů (zde 3) je vždy o


 

...konec náhledu článku...
Pokračuj dál

Znalosti v hodnotě stovek tisíc získáš za pár korun

Došel jsi až sem a to je super! Věříme, že ti první lekce ukázaly něco nového a užitečného.
Chceš v kurzu pokračovat? Přejdi do prémiové sekce.

Omezená nabídka: Nauč se vše a ušetři

Koupit lekce a funkce postupně a po jednom 330 bodů
Koupit všechny aktuálně dostupné lekce s funkcí odevzdávání úloh za exkluzivní cenu 281 bodů (700 Kč)
Na svém účtu máš aktuálně 0 bodů
Koupí tohoto výhodného balíčku získáš přístup ke všem 36 lekcím s kontrolou a certifikací a ještě navíc ušetříš 124 Kč. Nabídka je omezená pouze pro první lekce z kurzu a obsahuje exkluzivní slevu 15%.
281 bodů získáš za přidání svého článku na síť nebo odpovídá 823 Kč 700 Kč

Pozor, pokud si koupíš pouze tuto lekci, ztratíš nárok na speciální slevu 15% na balíček všech lekcí.

Koupit jen lekci 10 bodů
Na svém účtu máš aktuálně 0 bodů
10 bodů získáš za přidání svého článku na síť nebo odpovídá 25 Kč

Obsah článku spadá pod licenci Premium, koupí článku souhlasíš se smluvními podmínkami.

Co od nás v dalších lekcích dostaneš?
  • Neomezený a trvalý přístup k jednotlivým lekcím.
  • Kvalitní znalosti v oblasti IT.
  • Dovednosti, které ti pomohou získat vysněnou a dobře placenou práci.

Popis článku

Požadovaný článek má následující obsah:

Toto je poslední lekce na téma vzorců a funkcí. Seznámíme se v ní s vnořováním funkcí, operátory a zástupnými znaky, maticovými funkcemi a poloadresováním.

Body získáš, když podpoříš naši síť. To můžeš udělat buď zasláním symbolické částky na podporu provozu nebo přidáním obsahu na síť.

Článek pro vás napsal Petr Svoboda
Avatar
Petr
Aktivity (4)